summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-03-05 12:03:34 +0000
committerBioArchLinuxBot2024-03-05 12:03:34 +0000
commit397a2308356427cb6e29fbd625ba09e6c64a7b2c (patch)
tree42f7f9f3f4d9af639645c656b05f601949667340 /PKGBUILD
parentf0bdc84df82c946273c4413765106ad467b6f1a9 (diff)
downloadaur-r-ggdist.tar.gz
[lilac] updated to 3.3.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 11 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a8e1dfd63a9..afe49ff7d23e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,26 @@
# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=ggdist
-_pkgver=3.3.1
+_pkgver=3.3.2
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Visualizations of Distributions and Uncertainty"
arch=(x86_64)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(GPL3)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-or-later')
depends=(
r-cli
r-distributional
- r-dplyr
r-ggplot2
r-glue
+ r-gtable
r-numderiv
r-quadprog
r-rcpp
r-rlang
r-scales
r-tibble
- r-tidyselect
r-vctrs
r-withr
)
@@ -30,10 +29,8 @@ checkdepends=(
r-beeswarm
r-fda
r-fontquiver
- r-forcats
r-mvtnorm
r-posterior
- r-purrr
r-showtext
r-svglite
r-sysfonts
@@ -45,33 +42,31 @@ optdepends=(
r-beeswarm
r-broom
r-covr
- r-cowplot
+ r-dplyr
r-fda
r-fontquiver
- r-forcats
r-knitr
- r-modelr
r-mvtnorm
- r-palmerpenguins
r-patchwork
r-pkgdown
r-posterior
- r-purrr
+ r-ragg
r-rmarkdown
r-showtext
r-svglite
r-sysfonts
r-testthat
r-tidyr
+ r-tidyselect
r-vdiffr
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('1dd3ff51bdfffa5fc48032ace31a2470')
-sha256sums=('6705e8a252701bc162bbbe26f7cbb3e95e93a11af6288456ab711f5d0c0df929')
+md5sums=('4272ed3112d6770ed3bea3697eea180e')
+b2sums=('efbf4e460afcfc5092a8b8eba4bbfdab1dd55da087a9124ac3093e19a1505a6debd0b218ba607e251f4c5aadf68223800f555518c2b556cd59703030bcffe386')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {