summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Phinikarides2020-06-29 23:56:15 +0300
committerAlexander Phinikarides2020-06-30 02:35:57 +0300
commit7ef68731bd237e0e0157ee733b01229c16ae4339 (patch)
tree43abb846190397826166682eade39992261897ed /PKGBUILD
parentf65de6a11059614a065f98fa41c57144419e56d3 (diff)
downloadaur-7ef68731bd237e0e0157ee733b01229c16ae4339.tar.gz
update to v4.0.2
use mklvars.sh from community/intel-mkl
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df31c4d28b8b..4a3ea8113c7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# - jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
pkgname=r-mkl
-pkgver=4.0.0
+pkgver=4.0.2
pkgrel=1
pkgdesc="Language and environment for statistical computing and graphics, linked to the Intel(R) MKL."
arch=('x86_64')
@@ -51,7 +51,7 @@ source=("http://cran.r-project.org/src/base/R-${pkgver%%.*}/R-${pkgver}.tar.gz"
'R.conf'
'mklvars.sh')
-sha1sums=('91750d179ae23877e1fe92262f5206352d8683ba'
+sha1sums=('ee79a57730ed4786c0d6a05bd050d52a5d0290c1'
'dd214eee232b7aced7366722ad416b6b39be8e1b'
'af80774f5a8d0e669e8ff90662638a0f4e1105d7'
'43668da6cfd1b4455a99f23e79e2059294dddac9'
@@ -91,8 +91,13 @@ build() {
# Set up the environment for MKL
if [ -f /opt/intel/mkl/bin/mklvars.sh ]; then
+ echo "Sourcing /opt/intel/mkl/bin/mklvars.sh"
source /opt/intel/mkl/bin/mklvars.sh ${_intel_arch}
+ elif [ -f /usr/bin/mklvars.sh ]; then
+ echo "Sourcing /usr/bin/mklvars.sh"
+ source /usr/bin/mklvars.sh ${_intel_arch}
else
+ echo "Sourcing mklvars.sh"
source ../mklvars.sh ${_intel_arch}
fi