summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2024-10-01 19:42:41 +0300
committerPekka Ristola2024-10-01 19:42:41 +0300
commit292c2c726189ecada152ed1cabc9b5ee8a9d84c2 (patch)
treed66d3eb5f5f6fb4c447cf548b819aee71c3780af /PKGBUILD
downloadaur-r-mmod.tar.gz
Version 1.3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ade7f5c2536
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=mmod
+_pkgver=1.3.3
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Modern Measures of Population Differentiation"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('MIT')
+depends=(
+ r-adegenet
+ r-pegas
+)
+optdepends=(
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('957b63e23536053a16e24434d06b13d6')
+b2sums=('349cfb4fa0f60bc7cba4bb9564b2743744fdb70a0e492ad6a798d610f2f1a70dea237d224db3bf46f5f0e6ec175d86b8fb43b1581c1861c50d17b2215094f463')
+
+build() {
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}