summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-09 12:13:00 +0000
committerBioArchLinuxBot2024-04-09 12:13:00 +0000
commit39f9ce01bf3bd5eff5e93f5e0253a71d82802655 (patch)
treea47f508360b983e60d8660a119d829fbfa69974d /PKGBUILD
parent154d7b978f5c3a474dc0b5ed8feab35ec386e3ab (diff)
downloadaur-r-optextras.tar.gz
[lilac] updated to 2019.12.4-7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ef33ef8da8a..79b105267896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
_pkgname=optextras
_pkgver=2019-12.4
pkgname=r-${_pkgname,,}
-pkgver=2019.12.4
-pkgrel=4
-pkgdesc='Tools to Support Optimization Possibly with Bounds and Masks'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=7
+pkgdesc="Tools to Support Optimization Possibly with Bounds and Masks"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-only')
depends=(
- r
r-numderiv
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('59006383860826be502ea8757e39ed94338f04d246c4fc398a088e004d8b13eb')
+md5sums=('fd03bbc4c2390d48216937e04f7cc026')
+b2sums=('91be70c728ffdac7fba389143e9d40f281e9df23073fc289683ce6555dd767a53570c2af60d09a7e3d6a93d0237d84bea2620de2a96d4fcd64aecf29b1ea7d3f')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: