summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-05-02 18:42:10 +0000
committerBioArchLinuxBot2024-05-02 18:42:10 +0000
commit4b5abc4dd53f784d81414834faeef291ef5ed4a4 (patch)
treeb656f95210afb404c288257206dfe2211a222619 /PKGBUILD
parentceb6d43feea14316ada555bb953f8c7124783d08 (diff)
downloadaur-r-org.hs.eg.db.tar.gz
[lilac] updated to 3.19.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 151479c79c14..2191c82e1f8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=org.Hs.eg.db
-_pkgver=3.18.0
+_pkgver=3.19.1
pkgname=r-${_pkgname,,}
-pkgver=3.18.0
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Genome wide annotation for Human'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+pkgdesc="Genome wide annotation for Human"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('Artistic-2.0')
depends=(
- r
r-annotationdbi
)
optdepends=(
@@ -19,14 +18,15 @@ optdepends=(
r-runit
)
source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('41dc753ed5f4d31dcf0d645ef32b6339b1b70cc48b7c4c4673767643b129c5ca')
+md5sums=('cb39778028189b094a1baab5f6b0086f')
+b2sums=('5bd984d735199401d2b956e03b06cb0aa6b3e6f778b76e6e94da9dbb7be1ce1a061278910bc9253263e1494d007c5b96538123be8e8967a8405a96753e842cd7')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: