summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-10 12:05:58 +0000
committerBioArchLinuxBot2024-04-10 12:05:58 +0000
commit631f5c5db2bc4622893db6a321507c5c134fc4d6 (patch)
tree022ccb2a6bdcb53dfcb652ef70f16adabd83a791 /PKGBUILD
parenta5447308eed4c77846648358b3163bdcbad16e86 (diff)
downloadaur-r-r2winbugs.tar.gz
[lilac] updated to 2.1.22.1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab2197ce6c74..875cfd911a77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,30 @@
-# system requirements: OpenBugs for functions bugs() and openbugs() orWinBUGS 1.4 for function bugs()
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=R2WinBUGS
_pkgver=2.1-22.1
pkgname=r-${_pkgname,,}
-pkgver=2.1.22.1
-pkgrel=1
+pkgver=${_pkgver//-/.}
+pkgrel=2
pkgdesc="Running 'WinBUGS' and 'OpenBUGS' from 'R' / 'S-PLUS'"
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-only')
depends=(
- r
r-coda
)
optdepends=(
r-brugs
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('438e6241b96b73cf9adf51b5564fd27a14710256c93aa18e6b7382acc89d38a5')
+md5sums=('fed637512e1fa184fab761080cda95f9')
+b2sums=('a8f54b65b4d1b8216dc5a085b5dfc9c7bdc30eb0b2d684344ea7fc4ea6df9754d56af7bf06d44ec47d22e4e0e0721dec349c920949a2ebe3bdc0f0e9fa49c670')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: