summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-25 07:12:37 +0000
committerBioArchLinuxBot2024-04-25 07:12:37 +0000
commit7631fc68fb4f7ed9df68e561f4ff229360e9df57 (patch)
treec4831d8f91134e14f93e22fbe89930660b17cb09 /PKGBUILD
parent381968e969d050bb92a8df7b41ebfffb7111b04d (diff)
downloadaur-r-rstpm2.tar.gz
[lilac] updated to 1.6.3-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 623e78d1ac14..5b586ea1e6cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ _pkgname=rstpm2
_pkgver=1.6.3
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Smooth Survival Models, Including Generalized Survival Models"
arch=(x86_64)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(GPL)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-only OR GPL-3.0-only')
depends=(
blas
lapack
@@ -39,11 +39,11 @@ optdepends=(
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
md5sums=('2fb292e291b311986d90f7783f4e1ea2')
-sha256sums=('5e6079a876a43473768ee54e4b34081ea3b5e1f466f9f76e8cfc2bb461b2031f')
+b2sums=('50cd108d8b899f487528c8cfbcb3941902ba17b0220f5aebe38a5ff49629b193dc44a06659918df31efe0fd15a39512d04bc832226870e4e8374a4f22c2d441d')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {