summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:17:59 +0800
committerSukanka2022-06-07 02:17:59 +0800
commit5558c403365a5abb2522f06a515ea416b432fd8c (patch)
treeea074962479a1178a42eb6a75ba1bb7f1cf57a26 /PKGBUILD
downloadaur-r-txdb.mmusculus.ucsc.mm10.knowngene.tar.gz
add r-txdb.mmusculus.ucsc.mm10.knowngene
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeff384b8736
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TxDb.Mmusculus.UCSC.mm10.knownGene
+_pkgver=3.10.0
+pkgname=r-${_pkgname,,}
+pkgver=3.10.0
+pkgrel=4
+pkgdesc='Annotation package for TxDb object(s)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-genomicfeatures
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('696281749d01737c94894564d62093433045bc007a4528cc3d94f205edb54977')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: