summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2024-01-17 15:57:29 +0200
committerChristoph Fink2024-01-17 15:57:29 +0200
commitea8e1132327cc88802eb8b56427ab42416cb327f (patch)
treed0ec5077429195c3d8a483954014901eaa3a939b /PKGBUILD
parentcf6e85b4fcb5d404d29f2905a341bbdbf895312f (diff)
downloadaur-r-withr.tar.gz
upgpkg: r-withr 3.0.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a31a82233f19..66583c1f9d6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgdesc="Lightweight Well-Known Geometry Parsing"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=1
+pkgrel=2
arch=("any")
depends=(
@@ -40,24 +40,24 @@ optdepends=(
# the build chroot), uncomment the lines defining `checkdepends`, below,
# as well as the `check()` function further down
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat>=3.0.0"
- "texlive-core"
-)
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# "texlive-core"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-b2sums=('12ee381cbd50dfc7f2e1395d061bac5879e40c12f87a5952706987634ba097d7dd93854ed2997e81d5f18fa5b63508d550379652df4326914b42cd0aebb94968')
+b2sums=("12ee381cbd50dfc7f2e1395d061bac5879e40c12f87a5952706987634ba097d7dd93854ed2997e81d5f18fa5b63508d550379652df4326914b42cd0aebb94968")
build() {
mkdir -p "${srcdir}/build/"
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- export R_LIBS="build/"
- R CMD check --no-manual "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"