summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2023-05-02 07:31:19 -0400
committerTed Alff2023-05-02 07:31:19 -0400
commit558373c316796e71cb2a216d68910c8c25c98f89 (patch)
tree25807b52e6d6283d8c56afa4f53ee720d3f275e7 /PKGBUILD
parent3400aae91badcee997bf5f531f49ef9013789aeb (diff)
downloadaur-radiotray-ng.tar.gz
Add patch for gcc13 compatibility
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9906ecc3604..54240b385d6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=radiotray-ng
pkgver=0.2.8
-pkgrel=2
+pkgrel=3
pkgdesc="An Internet radio player for Linux"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/ebruck/radiotray-ng"
license=('GPL')
depends=('boost-libs' 'curl' 'gst-plugins-good' 'jsoncpp' 'libappindicator-gtk3'
@@ -12,12 +12,15 @@ depends=('boost-libs' 'curl' 'gst-plugins-good' 'jsoncpp' 'libappindicator-gtk3'
makedepends=('cmake' 'boost' 'lsb-release')
optdepends=('python-lxml: Convert radiotray bookmarks to radiotray-ng format')
options=('!libtool')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz")
-sha256sums=('5bc256c21c88d055d42ed44915e3d16642004327bf45597b9c7278c88b28a5cb')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz"
+ "${pkgname}"_gcc13_compilation_fix.patch::https://github.com/ebruck/radiotray-ng/commit/7a99bfa784f77be8f160961d25ab63dc2d5ccde0.patch)
+sha256sums=('5bc256c21c88d055d42ed44915e3d16642004327bf45597b9c7278c88b28a5cb'
+ '63d974314df9dfe6cb6a12d0468fbc02001d1d0420bdf1f75bef6e1b33702d13')
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
sed -i 's:-Werror::' CMakeLists.txt
+ patch -Np1 -i ../"${pkgname}"_gcc13_compilation_fix.patch
}
build() {