summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 19:10:30 +0200
committerMattias Andrée2015-06-11 19:10:30 +0200
commit42afd33af0bd66763082a2ea81ff2ced3264895a (patch)
treea83705e90a5af07e46539508a9de5aafe22dc5c8 /PKGBUILD
downloadaur-rc.local.d.tar.gz
Initial import, version 1396841433
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7387eb0e5db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=rc.local.d
+pkgver=1396841433
+pkgrel=1
+pkgdesc="Startup-system independent startup scripts"
+url="https://github.com/GNU-Pony/rc.local.d"
+arch=(any)
+license=(GPL3)
+depends=(bash)
+optdepends=(linux findutils kbd ntp alsa-utils)
+makedepends=(make coreutils general-preprocessor)
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(a74d39dd6e6825509112f9796e87b138ad1a810e6dd578bbacec1c47891e171e)
+
+
+build() {
+ cd "${srcdir}/rc.local.d-${pkgver}"
+ make PKGNAME="${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/rc.local.d-${pkgver}"
+ make PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+