summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-02-16 08:43:15 +0000
committerGeorge Rawlinson2022-02-16 08:43:15 +0000
commiteb2490bbb18a172870c0fd64003c174db2215efa (patch)
tree511f41ca49b7b22f14150feca5f3f878b9ea9221 /PKGBUILD
parente41b01b64090912c129d119c9188ca4630c3d238 (diff)
downloadaur-redo-python.tar.gz
upgpkg: redo-python 0.42.d-1
* New upstream release. * Add tests.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 44 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06d16d60640e..d8ba794ded70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,51 @@
-# Maintainer: buckket <felix@buckket.org>
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+# Contributor: buckket <felix@buckket.org>
pkgname=redo-python
-_pkgname=redo
-pkgver=0.42c
+pkgver=0.42.d
pkgrel=1
-pkgdesc="Redo implementation in Python."
-arch=("any")
-license=("GPL")
+pkgdesc="An implementation of the redo build system in Python"
+arch=('any')
+license=('GPL')
url="https://github.com/apenwarr/redo"
-depends=("python")
-makedepends=("python-beautifulsoup4")
-optdepends=("python-setproctitle: pretty output")
-provides=("redo")
-conflicts=("redo")
-source=("https://github.com/apenwarr/redo/archive/redo-${pkgver}.tar.gz")
-sha256sums=('6f1600c82d00bdfa75445e1e161477f876bd2615eb4371eb1bcf0a7e252dc79f')
+depends=('python')
+makedepends=(
+ 'git'
+ 'python-beautifulsoup4'
+ 'python-markdown'
+)
+optdepends=('python-setproctitle: pretty output')
+provides=('redo')
+conflicts=('redo-sh' 'redo-c' 'redo-jdebp')
+_commit='7f00abc36be15f398fa3ecf9f4e5283509c34a00' # redo-0.42d
+source=("$pkgname::git+$url.git#commit=$_commit")
+b2sums=('SKIP')
-package() {
- cd "${_pkgname}-${_pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}/" install
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed -e 's/^redo-//' -e 's/\([[:alpha:]]\)$/.\1/'
}
+check() {
+ cd "$pkgname"
+
+ local L_CFLAGS L_CXXFLAGS L_LDFLAGS
+ L_CFLAGS=$CFLAGS
+ L_CXXFLAGS=$CXXFLAGS
+ L_LDFLAGS=$LDFLAGS
+
+ unset CFLAGS CXXFLAGS LDFLAGS
+
+ make test
+
+ CFLAGS=$L_CFLAGS
+ CXXFLAGS=$L_CXXFLAGS
+ LDFLAGS=$L_LDFLAGS
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" install
+}