summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArjun Nemani2018-07-08 21:05:08 +0530
committerArjun Nemani2018-07-08 21:05:08 +0530
commita4eb83d0aaacf2b6af65b7ba177da82fe70a8a1b (patch)
tree4da42110b259c14c8da9e1c7ed4fc2b3da41dccb /PKGBUILD
downloadaur-remark-validate-links.tar.gz
Add npm remark-validate-links to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11cb480845a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=remark-validate-links
+_npmver=7.0.0
+pkgname=remark-validate-links # All lowercase
+pkgver=7.0.0
+pkgrel=1
+pkgdesc="Validate links to headings and files in markdown"
+arch=(any)
+url="https://github.com/wooorm/remark-validate-links#readme"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(31de803ac4682ea923b68a82560810981853d110)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: