summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author盐粒 Yanli2024-01-10 22:04:14 +0800
committer盐粒 Yanli2024-01-10 22:04:14 +0800
commita71173f058720c1292f26ea2d919e3b9681f91b3 (patch)
treec957e91a5e7a0e7d33ad3f2cd7df22da7fb6dd13 /PKGBUILD
downloadaur-replicate-cog-bin.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c99009e814a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Yanli <mail@yanli.one>
+pkgname=replicate-cog-bin
+pkgver=1.0.0
+pkgrel=1
+epoch=1
+pkgdesc='Containers for machine learning'
+arch=('x86_64' 'aarch64')
+url="https://github.com/replicate/cog"
+license=('unknown')
+depends=('curl')
+source=()
+sha512sums=()
+
+package() {
+ mkdir "${pkgdir}/usr/local/bin/" -p
+ curl -o "${pkgdir}/usr/local/bin/cog" -L https://github.com/replicate/cog/releases/latest/download/cog_`uname -s`_`uname -m`
+ chmod +x "${pkgdir}/usr/local/bin/cog"
+} \ No newline at end of file