summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2023-05-12 01:45:08 +0200
committerChristopher Arndt2023-05-12 01:45:08 +0200
commit54aca8f75653ce92bbe67ab911b12f4d1c048b45 (patch)
tree8c385d7037063c370f7620eb74785993b5eaf843 /PKGBUILD
parentbdc2292ef28bfb08fcde4a1f90158ce6db8755ab (diff)
downloadaur-restview.tar.gz
Update to upstream version 3.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4159bea47ed7..e63a8c6d417f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,24 @@
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
pkgname=restview
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
-pkgdesc="A viewer for ReStructuredText documents that renders them on the fly."
+pkgdesc='A viewer for ReStructuredText documents that renders them on the fly'
arch=(any)
-url="http://mg.pov.lt/restview/"
-license=('GPL')
-depends=('python-docutils' 'python-pygments' 'python-readme-renderer' 'python-setuptools')
-options=(!emptydirs)
-source=(
- "https://files.pythonhosted.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
-)
-sha256sums=('2b989610aaed2fd42da64f6cdc539cf3ee70ce370bcba872db72421ad515dd1e')
+url='https://mg.pov.lt/restview/'
+license=(GPL)
+depends=(python-docutils python-pygments python-readme-renderer)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('8c1a171c159d46d15d5569f77021828883a121d6f9baf758d641fc1e54b05ae5')
build() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- python setup.py build
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- python setup.py install --skip-build --root="${pkgdir}"/ --optimize=1
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
}