summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlily wilson2015-06-11 16:26:54 -0400
committerlily wilson2015-06-11 16:26:54 -0400
commit5bb3bddd5aea90d5d2c9ef25727ef29bc3409232 (patch)
tree8dc2354fc81d3ccce84be2c36bff9c17202b6e6b /PKGBUILD
downloadaur-retro-bzr.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3d21a1d0888
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+pkgname=retro-bzr
+pkgver=453
+pkgrel=1
+pkgdesc="Retro is a portable, stack-based language with roots in Forth."
+arch=('i686' 'x86_64')
+url="http://retroforth.com"
+license=('ISC')
+makedepends=('bzr' 'python-docutils')
+provides=('retro')
+install=
+source=()
+
+_bzrtrunk=lp:retro-language
+_bzrmod=retro
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to Bazaar server...."
+
+ if [[ -d "$_bzrmod" ]]; then
+ cd "$_bzrmod" && bzr pull "$_bzrtrunk" -r "$pkgver"
+ msg "The local files are updated."
+ else
+ bzr branch "$_bzrtrunk" "$_bzrmod" -q -r "$pkgver"
+ fi
+
+ msg "Bazaar checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_bzrmod-build"
+ cp -r "$srcdir/$_bzrmod" "$srcdir/$_bzrmod-build"
+ cd "$srcdir/$_bzrmod-build"
+
+ #
+ # BUILD HERE
+ #
+
+ make clean
+ make retro
+ make libdocs
+ make webdocs
+}
+
+pkgver() {
+ cd "$srcdir/$_bzrmod"
+ bzr revno
+}
+
+package() {
+ mkdir -p $pkgdir/usr/{lib/retro,bin,share/{man/man1,retro,licenses/retro,doc/retro/library}}
+
+ cd "$srcdir/$_bzrmod-build"
+
+ gzip -c9 doc/retro.1 > $pkgdir/usr/share/man/man1/retro.1.gz
+ xz -c9 LICENSE > $pkgdir/usr/share/licenses/retro/LICENSE.xz
+ cat image/{meta,kernel}.rx | xz -c9 - > $pkgdir/usr/share/retro/core.rx.xz
+
+ install -m755 retro $pkgdir/usr/bin/retro
+ install -m644 retroImage $pkgdir/usr/share/retro
+
+ cp www/docs/*.html $pkgdir/usr/share/doc/retro
+ cp www/docs/library/*.html $pkgdir/usr/share/doc/retro/library
+ cp library/* $pkgdir/usr/lib/retro
+}
+
+# vim:set ts=2 sw=2 et: