summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2015-05-30 14:09:33 +0200
committerCarsten Teibes2015-05-30 14:09:33 +0200
commit667c03aecc35dbb37e07da8c6288d0a778318070 (patch)
tree41fd468270e97c9c03407161e2f363a56fc458e8 /PKGBUILD
downloadaur-rhash-git.tar.gz
[add] rhash-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1af9567d712
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=rhash-git
+pkgver=1.3.3.r9.gbf59ce0
+pkgrel=1
+pkgdesc='Utility for verifying hash sums (SFV, CRC, etc) - development version'
+arch=('i686' 'x86_64')
+url='http://rhash.anz.ru/?l=en'
+license=('custom' 'MIT')
+conflicts=("rhash")
+provides=("rhash")
+depends=('glibc')
+backup=('etc/rhashrc')
+#options=('staticlibs')
+source=("git+https://github.com/rhash/rhash.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd rhash
+ git describe --long | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ make -C rhash ADDCFLAGS="$CFLAGS" ADDLDFLAGS="$LDFLAGS" build-shared lib-static
+}
+
+check() {
+ make -C rhash test-shared
+}
+
+package() {
+ cd rhash
+
+ # program
+ make PREFIX=/usr DESTDIR="$pkgdir" install-shared
+ # library
+ make -C librhash PREFIX=/usr DESTDIR="$pkgdir" install-headers install-lib-shared install-lib-static
+ # license
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/rhash/LICENSE
+}