summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdriĆ  Arrufat2015-07-15 19:47:17 +0200
committerAdriĆ  Arrufat2015-07-15 19:47:17 +0200
commit08ec2c0c2587f42233e076e4b68f29f03630fc68 (patch)
treec3ea3474c6e4fa81f6cf2c48d8526b09a7584ac0 /PKGBUILD
downloadaur-rhythmweb-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d681cebedd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Adria Arrufat <swiftscythe at gmail dot com>
+pkgname=rhythmweb-git
+pkgver=20121202
+pkgrel=1
+pkgdesc="GTK3 port of the original rhythmweb v0.1x GTK2 plugin - for Rhythmbox v2.96 and above"
+url="https://github.com/fossfreedom/rhythmweb"
+arch=('i686' 'x86_64')
+license=('GPL')
+makedepends=('git')
+depends=('rhythmbox')
+conflicts=('rhythmweb')
+provides=('rhythmweb')
+replaces=('rhythmweb')
+
+_plugin=rhythmweb
+_gitroot="https://github.com/fossfreedom/rhythmweb.git"
+_gitname="rhythmbox-$_plugin"
+
+build () {
+ cd ${srcdir}
+ msg "Connecting to the GIT server..."
+ if [[ -d ${srcdir}/${_gitname} ]] ; then
+ cd ${_gitname}
+ git pull origin
+ msg "The local files are updated..."
+ else
+ git clone ${_gitroot} ${_gitname}
+ cd ${_gitname}
+ fi
+ msg "GIT checkout done."
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ mkdir -p "${pkgdir}/usr/lib/rhythmbox/plugins/${_plugin}"
+ cp * "${pkgdir}/usr/lib/rhythmbox/plugins/${_plugin}"
+}