summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorasyncial2018-02-17 04:18:37 +0100
committerasyncial2018-02-17 04:18:37 +0100
commite22809474047d01ee1c3b1c50551a1b2e565446c (patch)
tree3e6b4c940cdaaccc49cf21cab70f876b0aa875e7 /PKGBUILD
downloadaur-ricerous-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1a3511509aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=ricerous-git
+pkgver=r55.4b6a828
+pkgrel=1
+pkgdesc="The diary of ricers."
+arch=(any)
+url="https://github.com/nixers-projects/ricerous"
+license=('GPL')
+depends=('python2-kivy' 'python2-setuptools')
+makedepends=('git')
+source=("ricerous::git+https://github.com/nixers-projects/ricerous")
+md5sums=('SKIP')
+options=(!emptydirs)
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}