summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNils Czernia2019-08-07 21:59:11 +0200
committerNils Czernia2019-08-07 21:59:11 +0200
commit105c9b1651a41bb073200499185f3613fa767e62 (patch)
treea6d57da22696f1a942d11040ae0868be5ea1ff95 /PKGBUILD
downloadaur-ricoh-spc261-ppd.tar.gz
Inital commi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dc28ed805c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ivan Naydonov <samogot@gmail.com>
+
+pkgname=ricoh-spc261-ppd
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="CUPS driver for Ricoh SP C 261DNw series"
+arch=("x86_64")
+url="http://support.ricoh.com/bb/html/dr_ut_e/re1/model/spc261dnw/spc261dnw.htm"
+license=("unknown")
+depends=("cups" )
+makedepends=("binutils" "p7zip")
+
+source=("http://support.ricoh.com/bb/pub_e/dr_ut_e/0001305/0001305295/V101/r80978en.exe")
+sha256sums=("a91017ab0ce697dff16d4a0f699c4525f87acc25b5ed673f8563f165c1416de6")
+
+prepare() {
+ ar x sp260-series-p-pcl-1.01-noarch.deb
+ tar -zxf data.tar.gz
+}
+
+package() {
+ install -d $pkgdir/usr
+ cp -a usr $pkgdir
+}