summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMassimiliano Torromeo2016-09-09 14:21:55 +0200
committerMassimiliano Torromeo2016-09-09 14:21:55 +0200
commit206595aa7e8fe24458ce589ba7eed3e98b3227d5 (patch)
treed6f0a5664eaba6e9ed063d7dc8398e0fd746883b /PKGBUILD
parenta719d72601673c1fec68bf3194083a58b0da2aff (diff)
downloadaur-206595aa7e8fe24458ce589ba7eed3e98b3227d5.tar.gz
Applied patch to fix the missing tray icon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e28b95f6f6f..48dc7afbff84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,12 +25,13 @@ sha256sums=('SKIP')
pkgver() {
cd "ring-kde"
-
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "ring-kde"
+ # fix missing tray icon
+ sed 's|setIconByPixmap(.*);|setIconByName("ring-kde");|' -i src/widgets/systray.cpp
}
build() {
@@ -45,6 +46,5 @@ build() {
package() {
cd "ring-kde/build"
-
make DESTDIR="$pkgdir" install
}