summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorraininja2023-11-03 22:37:36 -0400
committerraininja2023-11-03 22:37:36 -0400
commit6483e03ebbfde8e1cb1e944253c9fad4a6cf094f (patch)
tree793b82c877221a50abf131342a87a12c9eb30193 /PKGBUILD
downloadaur-riverwm-utils.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72c1e720058c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Dan Denkijin <dandenkijin at gmail dot com>
+# Maintainer: Dan Denkijin <dandenkijin at gmail dot com>
+
+pkgname=riverwm-utils
+pkgver=0.0.7.r8.gab7e631
+pkgrel=2
+pkgdesc="Utilities for the River Wayland compositor"
+arch=(any)
+url="https://github.com/NickHastings/${pkgname}"
+license=(GPLv3)
+makedepends=('git' 'python-installer' 'python-build' 'python-wheel')
+source=("git+${url}.git")
+md5sums=('SKIP')
+pkgver() {
+ cd $srcdir/$pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+build() {
+ cd $srcdir/$pkgname
+ python -m build --wheel --no-isolation
+}
+package() {
+ cd $srcdir/$pkgname
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+