summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-11-27 20:42:56 +0100
committerFabioLolix2023-11-27 20:42:56 +0100
commit89695709085d73b229bccdef677cad24e8923be1 (patch)
tree7f6db0a373e29bc545f86062ace82231e9c9f44a /PKGBUILD
parent9b3a695d33726e79a56e033df12f55f35d02fe50 (diff)
downloadaur-roc-toolkit-git.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD102
1 files changed, 65 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd5c0de78c7e..c1838db95cb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,82 @@
-# Maintainer: ronalde <r.v.engelen+aur@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: ronalde <r.v.engelen+aur@gmail.com>
# Contributor: dexterlb <dexterlb@qtrp.org>
-_pkgname=roc-toolkit
-pkgname=${_pkgname}-git
-pkgver=v0.1.5.r41.gc8968733
-pkgrel=2
-pkgdesc="Real-time audio streaming over network. Compiled without pulseaudio modules."
-arch=('x86_64' 'i686' 'armv6l' 'armv7l' 'aarch64' 'armv7h' 'armv6h')
-conflicts=(roc)
-provides=(roc-toolkit)
+pkgname=roc-toolkit-git
+pkgver=0.3.0.r0.g57b932b8
+pkgrel=3
+pkgdesc="Real-time audio streaming over network"
+arch=(x86_64 i686 armv7h aarch64)
url="https://github.com/roc-streaming/roc-toolkit"
-license=('MPL2')
-depends=('openfec' 'libuv' 'libunwind' 'sox')
-makedepends=('scons' 'clang' 'llvm' 'gengetopt' 'python' 'ragel' 'git')
-source=('git+https://github.com/roc-streaming/roc-toolkit.git')
+license=(MPL2)
+provides=(roc-toolkit)
+conflicts=(roc-toolkit roc)
+replaces=(roc)
+depends=(
+ glibc
+ gcc-libs
+ libunwind
+ libuv
+ openfec
+ speexdsp
+)
+makedepends=(
+ alsa-lib
+ cpputest
+ gengetopt
+ libpulse
+ ragel
+ scons
+ sox
+ git
+)
+optdepends=(
+ 'libpulse: for roc-conv, roc-receive and roc-send'
+ 'sox: for roc-conv, roc-receive and roc-send'
+)
+source=("git+https://github.com/roc-streaming/roc-toolkit.git")
sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "roc-toolkit"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-_run_scons() {
- local opts=(
- --prefix="${pkgdir}"/usr
- --disable-tests --disable-examples
- --disable-pulseaudio
- --with-openfec-includes=/usr/include/openfec
+build() {
+ local scons_options=(
+ --prefix=/usr
+ --libdir=/usr/lib
+ --disable-openssl # disable as it is not yet used
+ --enable-tests
+ --enable-examples
)
- scons ${opts[@]} "${@}"
+ cd "roc-toolkit"
+ scons "${scons_options[@]}"
}
-build() {
- cd "${_pkgname}"
- if [ -d 3rdparty ]; then
- _run_scons
- else
- if ! _run_scons; then
- # some libraries bundled as 3rd party components ship an outdated config.guess
- # file, which fails to detect some ARM systems
- find 3rdparty -name config.guess -exec cp -vf config.guess '{}' \;
- fi
- _run_scons
- fi
+check() {
+ local scons_options=(
+ --prefix=/usr
+ --libdir=/usr/lib
+ --disable-openssl # disable as it is not yet used
+ --enable-tests
+ --enable-examples
+ )
+
+ cd "roc-toolkit"
+ scons test "${scons_options[@]}"
}
package() {
- cd "${_pkgname}"
- _run_scons install
+ local scons_options=(
+ --prefix=/usr
+ --libdir=/usr/lib
+ )
+
+ cd "roc-toolkit"
+ scons DESTDIR="$pkgdir/" "${scons_options[@]}" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 3rdparty/hedley/COPYING -t "$pkgdir/usr/share/licenses/${pkgname}/hedley.COPYING"
}