summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYusuf Aktepe2022-12-30 02:40:59 +0300
committerYusuf Aktepe2022-12-30 02:40:59 +0300
commit49aab9ad335f415322ccfabc0a33efcb8e820a5b (patch)
treed03608310e74c6f1901fc60a616ca67aad55ecb0 /PKGBUILD
downloadaur-rofi-gpaste-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35bb1a703255
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Yusuf Aktepe <yusuf@yusufaktepe.com>
+
+pkgname=rofi-gpaste-git
+_pkgname=${pkgname%-git}
+pkgver=r33.e3f5313
+pkgrel=1
+pkgdesc="Rofi frontend for GPaste clipboard manager"
+arch=('any')
+url="https://github.com/yusufaktepe/rofi-gpaste"
+license=('GPL')
+depends=('rofi' 'gpaste' 'xclip' 'xdg-utils' 'xdotool' 'qrencode' 'zenity')
+makedepends=('git')
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${_pkgname}
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}