summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorReanGD2020-09-03 03:29:47 +0300
committerReanGD2020-09-03 03:29:47 +0300
commit7cd826601a7c5d0de78daadcde1b5a29e8c0c0ac (patch)
tree0dd3ad4a4cc1c76c79db7c2ed0acfcd2dd8ca314 /PKGBUILD
downloadaur-rofi-proxy.tar.gz
Adding a package rofi-proxy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67d036edd9a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ReanGD <reangd at yandex dot ru>
+pkgname=rofi-proxy
+pkgver=1.0
+pkgrel=1
+pkgdesc="plugin that allows you to manage rofi state with an external application"
+arch=(x86_64)
+url="https://github.com/ReanGD/rofi-proxy"
+license=('Apache')
+depends=(rofi)
+optdepends=()
+makedepends=(cmake)
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ReanGD/rofi-proxy/archive/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cmake \
+ -B "${pkgname}-${pkgver}/build" \
+ -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE:STRING='None' \
+ -Wno-dev
+ make -C "${pkgname}-${pkgver}/build" all
+}
+
+package() {
+ make -C "${pkgname}-${pkgver}/build" DESTDIR="$pkgdir" install
+}