summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhayao2023-04-27 00:40:04 +0900
committerhayao2023-04-27 00:40:04 +0900
commitec1a5e35bfd5e60ecc315c24d2118f984cfe4520 (patch)
tree1b8ed3bd8793cdd0338f397925b12f5a7b93983b /PKGBUILD
downloadaur-rofi-themes-collection-git.tar.gz
Add: Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f395f77650f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Yamada Hayao <hayao at fascode.net>
+
+pkgname="rofi-themes-collection-git"
+_pkgname=${pkgname%-git}
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Themes Collection for Rofi Launcher"
+arch=('any')
+url="https://github.com/newmanls/rofi-themes-collection"
+license=('GPL3')
+depends=('rofi')
+makedepends=('git')
+source=("git+$url")
+sha256sums=('SKIP')
+
+package(){
+ cd "$srcdir/${_pkgname}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 -t "$pkgdir/usr/share/rofi/themes/" themes/*
+}
+