summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-17 22:46:59 +0300
committerDimitris Kiziridis2020-07-17 22:46:59 +0300
commit0d5cb8bf6f758be44ac6e6c1ac8eea7b60abc9c5 (patch)
treed1ece65fa86ddea15f6f821d2b5f973f4142a8f1 /PKGBUILD
parent68e0ab050002123e4c13e18b044323f6d594f21f (diff)
downloadaur-roloviewer-bin.tar.gz
restructure package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0cc2462fa798..be6beb346e70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,6 @@ arch=('x86_64')
url='https://github.com/rosenloecher-it/roloviewer'
license=('GPL3')
provides=('roloviewer')
-depends=('zlib')
makedepends=('gendesk')
options=('!strip')
noextract=("${pkgname%-bin}-${pkgver}.AppImage")
@@ -28,6 +27,8 @@ package() {
--icon "${pkgname%-bin}"
install -Dm644 "${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -d "${pkgdir}/usr/bin"
- install -Dm755 "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.AppImage"
- ln -s /opt/roloviewer/${pkgname%-bin}.AppImage "${pkgdir}/usr/bin/roloviewer"
+ install -d "${pkgdir}/opt"
+ cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname%-bin}"
+ ln -s /opt/${pkgname%-bin}/AppRun "${pkgdir}/usr/bin/${pkgname%-bin}"
+ find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} +
} \ No newline at end of file