summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-01-27 10:04:26 +0900
committerBenjamin Chrétien2016-01-27 10:04:26 +0900
commit0b6c5e3da818bb9dec1e1f7bf273e8b4316c19f5 (patch)
treef06aa409f8ed47efe3ce0619361175aa90bda12f /PKGBUILD
parent423b7c6a5bffe6cff4df33255ed026a51f643509 (diff)
downloadaur-ros-indigo-ps3joy.tar.gz
Update to version 1.10.1 (pkgrel 1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29e2dd218f2e..37130b4bec60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - Playstation 3 SIXAXIS or DUAL SHOCK 3 joystick driver."
url='http://www.ros.org/wiki/ps3joy'
pkgname='ros-indigo-ps3joy'
-pkgver='1.10.0'
+pkgver='1.10.1'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -32,10 +32,16 @@ depends=(${ros_depends[@]}
libusb-compat
python2-pybluez)
-_tag=release/indigo/ps3joy/${pkgver}-${_pkgver_patch}
-_dir=ps3joy
-source=("${_dir}"::"git+https://github.com/ros-gbp/joystick_drivers-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/ps3joy/${pkgver}-${_pkgver_patch}
+# _dir=ps3joy
+# source=("${_dir}"::"git+https://github.com/ros-gbp/joystick_drivers-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="joystick_drivers-release-release-indigo-ps3joy-${pkgver}-${_pkgver_patch}"
+source=("https://github.com/ros-gbp/joystick_drivers-release/archive/release/indigo/ps3joy/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('e09af2c225201a38d9262715d76c9043288e816599e8daa738639a963e9f986d')
build() {
# Use ROS environment variables
@@ -57,6 +63,7 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}