summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-01-27 10:05:00 +0900
committerBenjamin Chrétien2016-01-27 10:05:00 +0900
commit69d68224145ae75727e305a15faa4603e439c58d (patch)
tree83eb44c19265b027092b052f111e70a88675c843 /PKGBUILD
parentf0a40bbf2a15cadca7cb165f950168f272aa4ab2 (diff)
downloadaur-ros-indigo-spacenav-node.tar.gz
Update to version 1.10.1 (pkgrel 1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c7a323edc08..aa03845ba0de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - ROS interface to the 3Dconnexion SpaceNavigator 6DOF joystick."
url='http://www.ros.org/wiki/spacenav_node'
pkgname='ros-indigo-spacenav-node'
-pkgver='1.10.0'
+pkgver='1.10.1'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -27,10 +27,16 @@ depends=(${ros_depends[@]}
libspnav
libx11)
-_tag=release/indigo/spacenav_node/${pkgver}-${_pkgver_patch}
-_dir=spacenav_node
-source=("${_dir}"::"git+https://github.com/ros-gbp/joystick_drivers-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/spacenav_node/${pkgver}-${_pkgver_patch}
+# _dir=spacenav_node
+# source=("${_dir}"::"git+https://github.com/ros-gbp/joystick_drivers-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="joystick_drivers-release-release-indigo-spacenav_node-${pkgver}-${_pkgver_patch}"
+source=("https://github.com/ros-gbp/joystick_drivers-release/archive/release/indigo/spacenav_node/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('e96f42eb851aec336358e07fc5a1b5802d1fde8416a08fab273b62ab7b10c745')
build() {
# Use ROS environment variables
@@ -52,6 +58,7 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}