summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:45:14 +0200
committerTim Rakowski2017-05-22 19:26:26 +0200
commitf8444615a44bbde3a142589de5d8696deae73e42 (patch)
treebd63bfec4bfe9798fbd2d259a228074a9a2226c2 /PKGBUILD
downloadaur-ros-lunar-xacro.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36550fb51d6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Xacro (XML Macros) Xacro is an XML macro language."
+url='http://ros.org/wiki/xacro'
+
+pkgname='ros-lunar-xacro'
+pkgver='1.12.0'
+_pkgver_patch=1
+arch=('any')
+pkgrel=2
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-roslint)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-roslaunch)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/xacro/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/xacro-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="xacro-release-release-lunar-xacro-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/xacro-release/archive/release/lunar/xacro/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('c1d072e08302cf630e01cdabd24af1cc219b44987466078e005deff44876e255')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}