summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbionade242020-07-06 15:36:36 +0200
committerbionade242020-07-06 15:36:36 +0200
commit60d0ea15c3c02ffbb265285e44be68700c61e261 (patch)
tree9adc61bc208cec3c3351d22e0d550d2c6c2941df /PKGBUILD
parent768d9ec512a69bc3954cc32afb668f7f162e85f9 (diff)
downloadaur-ros-melodic-tuw-msgs.tar.gz
Set python version to 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cfec1ad6a497..3ad24991d940 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-melodic-tuw-msgs'
pkgver='0.0.13'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-catkin)
@@ -44,14 +44,14 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \