summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbionade242020-02-18 20:07:13 +0100
committerbionade242020-02-18 20:07:13 +0100
commitc8ebfa494e48ec278ceb3ef857f64314b9f96ece (patch)
tree0e4766243d7c01a960901fbb4d6fa117beb075de /PKGBUILD
parentc9fadc085655f139291903c34fb668bc58fa4fac (diff)
downloadaur-ros-melodic-tuw-object-msgs.tar.gz
Updated package to python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 3 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c3e1546359b..71acc9d5a0eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,10 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - The tuw_object_msgs package."
url='https://wiki.ros.org/tuw_object_msgs'
pkgname='ros-melodic-tuw-object-msgs'
pkgver='0.0.13'
-_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-catkin
@@ -22,13 +19,6 @@ ros_depends=(ros-melodic-message-runtime
ros-melodic-std-msgs)
depends=(${ros_depends[@]})
-# Git version (e.g. for debugging)
-# _tag=release/melodic/tuw_object_msgs/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/tuw-robotics/tuw_msgs-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
-
-# Tarball version (faster download)
_dir="tuw_msgs-${pkgver}/tuw_object_msgs"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/tuw-robotics/tuw_msgs/archive/${pkgver}.tar.gz")
sha256sums=('b22f12be8014a8855cd179d228ae5312102da4b3d176979f66f13e258cc418b6')
@@ -43,17 +33,14 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}