summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammad Farzan2021-10-10 00:49:07 +0330
committerMohammad Farzan2021-10-10 00:49:07 +0330
commitf6b613244b08158472a6e02caec449421b690e49 (patch)
tree805847a414699809c6e6bfe59524051294bcafa8 /PKGBUILD
downloadaur-ros2-galactic-xacro.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09b89b1e301d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mohammad Mostafa Farzan <m2_farzan@yahoo.com>
+
+pkgname=ros2-galactic-xacro
+pkgver=r495.b8716fc
+pkgrel=1
+pkgdesc="A tool to construct shorter and more readable XML files by using macros that expand to larger XML expressions"
+url="https://index.ros.org/p/xacro/"
+arch=('any')
+depends=('ros2-galactic'
+ 'python-yaml'
+)
+source=("xacro::git+https://github.com/ros/xacro#branch=ros2")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/xacro
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ source /opt/ros2/galactic/setup.sh
+ colcon build --merge-install
+}
+
+package() {
+ # Copy build files
+ mkdir -p $pkgdir/opt/ros2/galactic
+ cp -r $srcdir/install/* $pkgdir/opt/ros2/galactic/
+ # Exclude files that clash with base ros installation
+ rm $pkgdir/opt/ros2/galactic/*setup.*
+ rm $pkgdir/opt/ros2/galactic/_local_setup*
+ rm $pkgdir/opt/ros2/galactic/COLCON_IGNORE
+}