summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan Douglas Scott2019-09-02 13:26:00 -0700
committerIan Douglas Scott2019-09-02 13:26:00 -0700
commit045ad3cb739d83cffaf4f2dc3ff9bf6362729e0f (patch)
tree4ac9ff1a90abe1fae850b3fca900d7f2d4f7614e /PKGBUILD
parent4fc0e24ecca7428e5671726d924a878f9136128c (diff)
downloadaur-rpython.tar.gz
upgpkg: rpython 0.2.1-1
upstream release Use seperate build() and package()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05e08d212420..bb3da33bff88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Ian Douglas Scott <ian@iandouglasscott.com>
pkgname=rpython
-pkgver=0.1.4
-pkgrel=2
+pkgver=0.2.1
+pkgrel=1
pkgdesc="Restricted python compiler"
url="http://pypy.org"
arch=('any')
depends=('python2' 'python2-setuptools' 'python2-pytest')
license=('MIT')
source=("https://pypi.python.org/packages/source/r/rpython/rpython-${pkgver}.tar.gz")
-md5sums=('680fcee2fed5f94fcb4390130510eec9')
+md5sums=('07b38960ceb4ae9bb10ab99ceedef888')
prepare() {
cd ${pkgname}-$pkgver
@@ -17,7 +17,12 @@ prepare() {
sed -i "s|os.path.realpath(os.path.join(MAINDIR, '_cache'))|os.path.expanduser('~/.cache/rpython')|" rpython/config/translationoption.py
}
+build() {
+ cd ${pkgname}-$pkgver
+ python2 setup.py build
+}
+
package() {
cd ${pkgname}-$pkgver
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}