summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJack Chen2021-03-14 06:57:31 +0800
committerJack Chen2021-03-14 07:40:17 +0800
commit1e91a63c0fb5885642cd95d4598369aa8a07ef9c (patch)
tree458838eb47967398f90c4bcca9779b41e278dfff /PKGBUILD
parent03e5121195d9010666982001edfcc517766993ae (diff)
downloadaur-rtl8761b-fw.tar.gz
update to 20201202
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22d196f03c15..dadf56ef86eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: Jack Chen <redchenjs@live.com>
pkgname=rtl8761b-fw
-pkgver=20200816
-pkgrel=2
+pkgver=20201202
+pkgrel=1
pkgdesc="Realtek bluetooth firmware for RTL8761B based devices"
arch=('any')
-url="https://github.com/Realtek-OpenSource/android_hardware_realtek"
+url="https://www.xmpow.com/pages/download"
license=('unknown')
source=(
- "https://raw.githubusercontent.com/Realtek-OpenSource/android_hardware_realtek/rtk1395/bt/rtkbt/Firmware/BT/rtl8761b_fw"
- "https://raw.githubusercontent.com/Realtek-OpenSource/android_hardware_realtek/rtk1395/bt/rtkbt/Firmware/BT/rtl8761b_config"
+ "https://mpow.s3-us-west-1.amazonaws.com/mpow_BH519A_driver+for+Linux.7z"
)
sha512sums=(
- '53f6cac0f001cbcb2fe461d00a8d5f68bdb28a620251954f4c3e5036a61a8aae23b863b31cbaed4233cf4e94b558ccd4ee8f965eeab43101406dc3646dc2be43'
- '4ce44ea672cc328b0c0c8070355bceba875e4fdbfae05193077b78022c980d1bade01fc7ba96165eca36ad11ffa8dc396b5a9f44a64e2a4f3adc717480b5959b'
+ '94b45a07c3a2e0650e64b1b52bd2b0b35546b7073dc7c8850b319d164adb66bf41e6d7fa0a20a7170ca264922e4780ea09205332d60eb5037994615303ce7307'
)
package() {
+ cd "$srcdir/${pkgver}_LINUX_BT_DRIVER/rtkbt-firmware/lib/firmware/rtlbt"
+
install -Dm644 rtl8761b_fw "$pkgdir/usr/lib/firmware/rtl_bt/rtl8761b_fw.bin"
install -Dm644 rtl8761b_config "$pkgdir/usr/lib/firmware/rtl_bt/rtl8761b_config.bin"
+
+ echo 'options btusb enable_autosuspend=0' | install -Dm644 /dev/stdin "$pkgdir/etc/modprobe.d/btusb.conf"
}