summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-06-08 23:42:33 +0200
committerGoliathLabs2020-06-08 23:42:33 +0200
commita434a1de8d7e6ac5a0fde797057d0faf531415ce (patch)
treea3504100c927ea1197cb8ff44318b7e77aa434fa /PKGBUILD
downloadaur-rtl8822bu-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0d4f48f6eb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contriubtor: Manuel Conzelmann <manolo89@online.de>
+
+_pkgname=rtl8822bu
+pkgname=$_pkgname-git
+pkgver=r51.9438d45
+pkgrel=1
+pkgdesc="Driver for the Realtek 822bu chipset."
+arch=("x86_64")
+url="https://github.com/EntropicEffect/rtl8822bu"
+license=('unknown')
+depends=("dkms")
+makedepends=('linux-headers' 'git' 'bc')
+source=("git+https://github.com/EntropicEffect/rtl8822bu.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make -j`cat /proc/cpuinfo |grep "processor"|wc -l`
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ mv 88x2bu.ko $pkgname.ko
+ install -m 755 -d $pkgdir/usr/lib/modules/$(uname -r)/
+ install -p -m 644 $pkgname.ko $pkgdir/usr/lib/modules/$(uname -r)/
+# depmod -b $pkgdir -a
+}