summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Holthuis2016-07-19 04:50:43 +0200
committerJan Holthuis2016-07-19 04:54:02 +0200
commit7e1fd5999e690ef43f1e6b4595cca4e098b768fa (patch)
tree657d9c9244e4c8e39dec00b9cccb12738efff354 /PKGBUILD
downloadaur-rubtexfonts2009.tar.gz
Inital version added
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6161f6bfc1f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jan Holthuis <holthuis.jan@gmail.com>
+
+pkgname=rubtexfonts2009
+pkgver=0.0.20120318
+pkgrel=1
+pkgdesc="Fonts for the Corporate Design of the Ruhr-University of Bochum. You need to download the files manually, using your LoginID from: https://noc.rub.de/~jobsanzl/latex/rubtexfonts-latest.tar.gz"
+arch=('any')
+url="https://noc.rub.de/~jobsanzl/latex/"
+license=('unknown')
+depends=('texlive-core' 'texlive-fontsextra')
+install=$pkgname.install
+source=("rubtexfonts-latest.tar.gz::file://rubtexfonts-latest.tar.gz")
+sha256sums=('c6a08662ee21f96a5ae1ea0b7d074e87e4bfa9476af2ef31429be4ab09bc479c')
+
+package() {
+ TEXMFDIST=$(kpsewhich -var-value=TEXMFDIST)
+ install -d -m755 "${pkgdir}/${TEXMFDIST}"
+
+ for subdir in "doc" "tex" "fonts" "source"; do
+ cp -r "${subdir}" "${pkgdir}/${TEXMFDIST}/${subdir}"
+ done
+
+ cd "${pkgdir}/${TEXMFDIST}"
+ find . -type d -exec chmod 755 {} \;
+ find . -type f -exec chmod 644 {} \;
+}