summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorivan2017-02-12 16:55:22 +0800
committerivan2017-02-12 16:55:22 +0800
commit6de38f70916b2a584f6eae1008aa4037ed214395 (patch)
tree8142afe88720ac15cefb04505cd785f70de015be /PKGBUILD
downloadaur-ruby-commander-4.1.5.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c7a05ca4c7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: ivan <qw7692336@gmail.com>
+
+_gemname=commander
+pkgname=ruby-$_gemname-4.1.5
+pkgver=4.1.5
+pkgrel=1
+pkgdesc='The complete solution for Ruby command-line executables'
+arch=(any)
+url='http://visionmedia.github.com/commander'
+license=()
+depends=(ruby ruby-highline-1.6)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('d5506fd05de0c6e835926c9b1b38f1005e11803b')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ # non-HEAD version should not install any files in /usr/bin
+ rm -r "$pkgdir/usr/bin/"
+}