diff options
author | Claudia Pellegrino | 2025-05-09 14:43:38 +0200 |
---|---|---|
committer | Claudia Pellegrino | 2025-05-09 14:48:29 +0200 |
commit | 99e210cbc349f92cf8e5bf204912b650d006f911 (patch) | |
tree | 66edb5a4e711fd7c74d55a485a71d0116ca9f1cb /PKGBUILD | |
parent | ca8787b80531a68a4b1512e1e4888669dc4a8bdb (diff) | |
download | aur-ruby-dry-core.tar.gz |
1.1.0-2: remove circular dependency, fix tests
- Bring back and refresh the patch to fix `inflector_spec`
- Remove `class_attributes_spec` to resolve a circular dependency to
`ruby-dry-types` [1] in checkdepends
- Add missing optdepends entries for the inflection feature (need at
least one of them installed at runtime to use the feature)
- Add comment to explain why we are patching out the specs
[1]: https://aur.archlinux.org/packages/ruby-dry-core#comment-1021026
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 31 |
1 files changed, 26 insertions, 5 deletions
@@ -3,7 +3,7 @@ _gemname='dry-core' pkgname="ruby-${_gemname}" pkgver=1.1.0 -pkgrel=1 +pkgrel=2 pkgdesc='A toolset of small support modules used throughout the dry-rb ecosystem' arch=('any') url="https://github.com/dry-rb/${_gemname}" @@ -20,20 +20,41 @@ checkdepends=( ruby-activesupport ruby-bundler ruby-dry-inflector - ruby-dry-types ruby-rake ruby-rspec ) +optdepends=( + 'ruby-activesupport: inflection backend (preferred)' + 'ruby-dry-inflector: inflection backend' +) options=('!emptydirs') -source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz") -sha512sums=('2649b04c95b9e53048808c5df6a1346f6c54c862bac6d164aa8c4c4f5f333d778c555fa081cbbaedab83925e72027b6391418f6857936a4d8a0940005f8c0d52') -b2sums=('ec1cca6b3eba5d23c721993d681c1518e1f5466714dad0b6a7e77f1a5de5c5f805ff49ece775569fc257e5106f597e0cec610776aaa06a0cc298d79e3a9d1228') +source=( + "${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz" + "${pkgname}_fix_tests.patch" +) +sha512sums=( + '2649b04c95b9e53048808c5df6a1346f6c54c862bac6d164aa8c4c4f5f333d778c555fa081cbbaedab83925e72027b6391418f6857936a4d8a0940005f8c0d52' + 'b2a0920f7a1724874d681edea4ab1c67330bbb484298fa8af55495c9f99fcf1105f77935667934f1848fdb1373b90b13eaf25d2ad50aa8211bf39902e02c5507' +) +b2sums=( + 'ec1cca6b3eba5d23c721993d681c1518e1f5466714dad0b6a7e77f1a5de5c5f805ff49ece775569fc257e5106f597e0cec610776aaa06a0cc298d79e3a9d1228' + 'b895adaa6a0fc35eac0cde70b74f799aebff78ca6df4291ce4f7534bec613d31f6bbcd62a46ce273b31d2b2d0439e1bba900ef74c1220c2d69ba2376cd6a29e1' +) prepare() { cd "${_gemname}-${pkgver}" # update gemspec/Gemfile to allow newer version of the dependencies sed --in-place --regexp-extended 's|~>|>=|g' "${_gemname}.gemspec" + + # Exclude tests for `inflecto`, a dependency which is both optional + # (i.e., unused if one of `activesupport/inflector` or `dry/inflector` + # is available) and unmaintained upstream. + patch --verbose --strip=1 --input="../${pkgname}_fix_tests.patch" + + # Exclude spec which would induce a circular checkdepends to + # `ruby-dry-types` + rm --force --verbose spec/dry/core/class_attributes_spec.rb } build() { |