summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBert Peters2024-03-28 22:50:01 +0100
committerBert Peters2024-03-28 22:50:01 +0100
commitc83748b9fa01b340c2a9edd6cd39d11e5be2ebea (patch)
tree28769996e18e66d4fb528b29c11fb8b8b4872c7a /PKGBUILD
parent7186fc5fee2ec2d8b1bb3d68934f82d5b109a8a4 (diff)
downloadaur-ruby-http_parser.rb.tar.gz
upgpkg: ruby-http_parser.rb 0.8.0-2
Fix license and remove cache file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2985ee71088c..40cd0ea7cb6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Maintainer: Bert Peters <bert@bertptrs.nl>
+# Contributor: Mario Finelli <mario dot finelli at yahoo dot com>
_gemname=http_parser.rb
pkgname=ruby-$_gemname
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Ruby bindings to https://github.com/ry/http-parser and https://github.com/a2800276/http-parser.java"
arch=(i686 x86_64)
url='http://github.com/tmm1/http_parser.rb'
@@ -20,4 +21,10 @@ package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+
+ # Install license in correct spot
+ install -t "$pkgdir/usr/share/licenses/$pkgname" -Dm644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE-MIT"
+
+ # Remove pointless cache file
+ rm "$pkgdir/$_gemdir/cache/"*.gem
}