summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVojtěch Aschenbrenner2015-07-15 12:46:46 +0200
committerVojtěch Aschenbrenner2015-07-15 12:46:46 +0200
commit91df5ba7fb3d16ccf2c30a527d8336c17605e2b1 (patch)
tree7770d8d5dd87c9adb2e8a9b54a6a6b5591083256 /PKGBUILD
downloadaur-ruby-ncursesw.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ab3b5428512
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Vojtěch Aschenbrenner <v@asch.cz>
+
+_gemname=ncursesw
+pkgname=ruby-$_gemname
+pkgver=1.4.9
+pkgrel=1
+pkgdesc='This wrapper provides access to the functions, macros, global variables and constants of the ncurses library. These are mapped to a Ruby Module named "Ncurses": Functions and external variables are implemented as singleton functions of the Module Ncurses.'
+arch=(i686 x86_64)
+url='http://github.com/sup-heliotrope/ncursesw-ruby'
+license=(LGPL-2.1)
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('18ae6580bf8ead6a48ed1e63eb2b44dc71dc0002')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}