summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames An2017-03-17 15:59:08 -0400
committerJames An2017-03-17 15:59:08 -0400
commitce5eb01e6d932e69ea9b35260567763fb21f81d6 (patch)
treeb4b46b5203e51885074d8b3119e83142c7ef552d /PKGBUILD
downloadaur-ruby-props.tar.gz
Initial commit with working PKGBUILD generated by gem2arch.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef9aca567a79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: James An <james@jamesan.ca>
+
+_gemname=props
+pkgname=ruby-$_gemname
+pkgver=1.1.2
+pkgrel=1
+pkgdesc='props - Manage Settings Hierachies (Commandline, User, Home, Defaults, etc.)'
+arch=(any)
+url='https://github.com/rubylibs/props'
+license=('Public Domain')
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('3e138b6bbbb8789d4fa83702659079a9b17ef6e8')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}