summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJörg Thalheim2015-09-02 23:36:20 +0200
committerJörg Thalheim2015-09-02 23:36:20 +0200
commita1ba36011d026f9caba9190d55336d0b9ff2e37e (patch)
treeebb22ba571320f93a6fedeed3412dba078c20b7e /PKGBUILD
downloadaur-ruby-rbeautify.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a262ac6f213
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Jörg Thalheim <joerg@higgsboson.tk>
+
+_gemname=rbeautify
+pkgname=ruby-$_gemname
+pkgver=0.0.7
+pkgrel=1
+pkgdesc='prettifier/beautifier for Ruby code [from http://www.arachnoid.com/ruby/]'
+arch=(any)
+url='http://github.com/rogerdpack/rbeautify'
+license=()
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('f0880b7580e9d4e03376cf0cf84593d70812d0ef')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}