summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoberto Valentini2018-01-24 11:27:32 +0100
committerRoberto Valentini2018-01-24 11:27:32 +0100
commit64055e53039ee1190eef2b4ae955a16c798a23d3 (patch)
tree61e9c4344888877d510e329c3b8879967e3d1b63 /PKGBUILD
downloadaur-ruby-settingslogic.tar.gz
New settingslogic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cde2d28b407
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer Valantin <valantin89 [at] gmail [dot] com>
+
+_gemname=settingslogic
+pkgname=ruby-$_gemname
+pkgver=2.0.9
+pkgrel=1
+pkgdesc='A simple and straightforward settings solution that uses an ERB enabled YAML file and a singleton design pattern.'
+arch=(i686 x86_64)
+url='https://github.com/binarylogic/settingslogic'
+license=(MIT)
+depends=('ruby')
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/${_gemname}-${pkgver}.gem")
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('5925a91d0d48dfb59a6e48ae2bb9c9b801fe6fab25a8e8d302ce8699d92f2ae6')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install --no-document -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" $_gemname-$pkgver.gem
+ rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"
+}