summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2016-12-27 21:14:26 -0500
committerMario Finelli2016-12-27 21:14:26 -0500
commit228bd3a71c68890ff52191b2f8a4371eb53ca423 (patch)
tree28dca7255529c0088e8e7db09de2b00bfc9b7d9f /PKGBUILD
downloadaur-ruby-url_mount.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee0ed51c7960
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+_gemname=url_mount
+pkgname=ruby-$_gemname
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Glue to allow mounted rack applications to know where they're mounted."
+arch=(any)
+url='https://github.com/hassox/url_mount'
+license=(MIT)
+depends=(ruby ruby-rack)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('44b98f9d08ed550a1421679fdf2e1c112bce66950f87a63c6205d4783a0566ad')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}