summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Yan2015-07-23 20:25:05 +0800
committerFelix Yan2015-07-23 20:25:05 +0800
commit8bd3e7a885e82ca2676ce605ea1893cf09d09499 (patch)
tree4e63ad6ff72ad3cdf71f5c3bed2e5c5aa4b280c6 /PKGBUILD
downloadaur-ruijieclient.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a52ae9dbdf62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: imagelife <lovelinux229@gmail.com>
+pkgname=ruijieclient
+pkgver=1.0_rc1
+_filename=$pkgname-1.0-rc1
+pkgrel=1
+pkgdesc="A More Powerful Ruijie Supplicant For GNU/Linux"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/ruijieclient/"
+license=('LGPL3')
+depends=('libpcap' 'libxml2')
+source=(http://ruijieclient.googlecode.com/files/$_filename.tar.gz)
+md5sums=('f1e343e4422d67d723a16e7fde977c16')
+
+build() {
+ cd "${srcdir}/${_filename}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_filename}"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: