summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFélix Piédallu2016-07-06 16:23:21 +0200
committerFélix Piédallu2016-07-06 16:23:21 +0200
commit84c88f7583e41bf34a4d65649e9dd154753135d3 (patch)
treeab51a02f23f17c1ca8521a97ba8450f15f6e0c87 /PKGBUILD
downloadaur-rust-book-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f247b08269ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Salamandar <felix@piedallu.me>
+
+pkgname=rust-book-git
+pkgver=20160706
+pkgrel=1
+pkgdesc="An offline version of rust-lang.github.io/book, the official documentation for the Rust language (git already compiled version)"
+arch=('any')
+url="https://doc.rust-lang.org/book/"
+license=('MIT')
+
+source=("git+https://github.com/rust-lang/book#branch=gh-pages")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/book"
+ mkdir -p ${pkgdir}/usr/share/doc/rust/book
+ cp -R * "${pkgdir}/usr/share/doc/rust/book/"
+}