summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThiago Kenji Okada2015-06-01 19:56:24 -0700
committerThiago Kenji Okada2015-06-08 22:02:24 -0300
commit513c3f23bac1ffafc4ed1ab26ac3aba94e35b051 (patch)
treec497fa86467a7fd9e0f17ffe5d8953eb883c270f /PKGBUILD
downloadaur-rutorrent-mobile-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93fe4a4fca31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Thiago Kenji Okada <thiago DOT mast3r AT gmail DOT com>
+
+pkgname='rutorrent-mobile-git'
+pkgver=0.9.r78.gcc47ee8
+pkgrel=1
+pkgdesc=' Plugin for ruTorrent to use it with mobile devies (Android, iOS, etc)'
+arch=('any')
+url='https://github.com/xombiemp/rutorrentMobile/'
+license=('GPL3')
+depends=('rutorrent')
+makedepends=('git')
+source=('git+https://github.com/xombiemp/rutorrentMobile.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/rutorrentMobile"
+ git describe --long | sed 's/release//; s/\([^-]*-g\)/r\1/; s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/rutorrentMobile"
+ mkdir -p "${pkgdir}/usr/share/webapps/rutorrent/plugins/mobile"
+ cp -r * "${pkgdir}/usr/share/webapps/rutorrent/plugins/mobile"
+ cd "${pkgdir}/usr/share/webapps/rutorrent/plugins/mobile"
+ rm -rf .git*
+}