summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergio Correia2022-01-10 18:09:21 -0300
committerSergio Correia2022-01-10 18:09:21 -0300
commit228e274e6bd7218024d358c908e5a483a07b967b (patch)
tree60101597370cb25e60f2e3cb47d6d9ed3d89e50d /PKGBUILD
parent7d22056c73c06e2921cdc265eac2aa8c9552f381 (diff)
downloadaur-ryzen-stabilizator-git.tar.gz
Add go mod init when building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d61b653cf5e..678082eb995e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ryzen-stabilizator-git
_pkgname=ryzen-stabilizator
pkgver=r19.90a2f7a
-pkgrel=1
+pkgrel=2
pkgdesc="Simple Go program to enable/disable C6 C-state, processor boosting, address space layout
randomization (ASLR) and the Power Supply Idle Control workaround on an AMD Ryzen processor, in
order to help with the infamous 'MCE-random-reboots-while-idle' issue."
@@ -36,6 +36,7 @@ prepare() {
build() {
export GOPATH="${srcdir}/go"
cd "${GOPATH}/src/${_pkgname}"
+ go mod init
go get
go build -ldflags "-X main.version=${pkgver}-${pkgrel}"
}