summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2024-01-19 16:37:29 +0100
committeraksr2024-01-19 16:37:29 +0100
commit53cd1c134fda3f83c078ec14ce625c6a178b959b (patch)
tree222ad6ee27061d537edfe894a21ac3da395ce1ff /PKGBUILD
parent5d32cbd45e2998ee9a320173026b47a49ecfac9d (diff)
downloadaur-sam-git.tar.gz
...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 15 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6e6ec79ead4..052071c1b753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,31 @@
# Maintainer: aksr <aksr at t-com dot me>
pkgname=sam-git
-pkgver=r461.cd8efea
+pkgver=r473.5d8acb3
pkgrel=1
-epoch=
-pkgdesc="An updated version of the sam text editor."
+pkgdesc='An updated version of the sam text editor.'
arch=('i686' 'x86_64')
-url="https://github.com/deadpixi/sam"
+url='https://github.com/deadpixi/sam'
license=('custom')
-categories=()
-groups=()
-depends=()
makedepends=('git')
-optdepends=()
-checkdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-changelog=
-install=
-source=("$pkgname::git+https://github.com/deadpixi/sam.git")
-noextract=()
+source=("$pkgname::git+$url")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/$pkgname"
- make
+ cd "$srcdir/$pkgname"
+ make
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/usr" install
- install -Dm644 README.rst $pkgdir/usr/share/doc/${pkgname%-*}/README.rst
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
- cd doc; for i in sam.ps se.ps samrc; do
- install -Dm644 $i $pkgdir/usr/share/doc/${pkgname%-*}/$i
- done
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/usr" install
+ install -Dm644 README.rst $pkgdir/usr/share/doc/${pkgname%-*}/README.rst
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+ cd doc; for i in sam.ps se.ps samrc; do
+ install -Dm644 $i $pkgdir/usr/share/doc/${pkgname%-*}/$i
+ done
}
-